Creating my node, step by step

Hello !

I’ve followed every step from the doc to become a delegate, now it’s done :smiley:

I’m very new with Linux, but I love challenge. Here’s my config :
Ubuntu 18.04.4 LTS
RAM : 7,3 Go
Processor : AMD® A12-9720p radeon r7, 12 compute cores 4c+8g × 4
Graphics : AMD® Radeon r7 graphics
Gnome : 3.28.2

I tried to install everything from a shared mobile connexion, but it seems that the documentation and the account registration isn’t working.
Now that I found a stable wifi I finished to get registred and got my @unikname ! =^^=

Now, I want to forge so I guess I must install my own node but… I don’t understand how it works.
I’ve installed Docker and the docker run hello-world command answered me correctly “Hello from docker”.
But when I’m trying to run the docker-compose up after getting the .yml file, it says :
curl: (6) Could not resolve host: docker-compose
curl: (6) Could not resolve host: up

Which isn’t really nice :sweat_smile:
I guess I have to open up some ports but I don’t how to do it in Linux. Did I miss something somewhere ?

Hey! From what I understand, you probably are running the curl docker-compose command instead of docker-compose. What have you entered exactly ?

You can get your commands history using the following command:

history -a && history
1 Like

Indeed, it’s because if I write the docker-compose it says :
bash: /usr/local/bin/docker-compose: Permission denied
that’s why I tried something else

Do you have root permissions ? (sudo)

1 Like

As @rigwild says, try your command with sudo.

sudo docker-compose up

Stay us tuned!

ok it was sillier than that, I didn’t install the executable permissions to the binary… --’
I’ll keep following the doc to be able to forge this evening !


I’m not sure if it’s good… There’s some action but I’m not seeing myself as active in the explorer :confused:

And half an hour after that

Ok I have some Error message now. I to moved the .yml to the “Docker” folder but I’m not sure it was a brillant idea x)

Thank you @Konohime for reporting this issue, other nodes have the same problem.
We are investigating.

Synchronization from the begin of the Blockchain should work.

Can you try:

$ sudo docker-compose down -v        # Stop and remove all UNS docker containers
$ sudo docker-compose pull           # Get the newest version of UNS Core
$ sudo docker-compose up -d --build  #  Restart all UNS containers
1 Like

Mmh… Well, I don’t have error message anymore but I’m still not forging anything ^^’

Something, somewhere, went wrong… But I don’t know where. I’m going to uninstall everything and restart from the beginning.

Hi @Konohime!

Our UNS Core 4.2.5 is live on SANDBOX network!

Your issues should be fixes with this update. You can try ton install your node again. :slight_smile: