Uns-cli installation build errors

Hello :slightly_smiling_face:

During the uns-cli installation, I had build errors. I figured out that I had to install the build-essential package (Ubuntu, Debian).

It is required to compile native dependencies with node-gyp (like bcrypt) when doing the installation.

It could be nice to add it to the documentation as it is something hard to debug (error log was unclear about the missing requirements).

For Windows, you can use https://www.npmjs.com/package/windows-build-tools, which provides python, vs-build-tools and gcc/g++.

1 Like

Hello @rigwild
Thank you for reporting this!

We will improve our documentation by adding your advices.

In the future, we will release binaries to install on your operating system, in order to avoid compilation steps (native for Linux, Mac and Windows).

Thank you

1 Like

Hi @rigwild,

The documentation has been updated and a dedicated topic has been opened to track all ways to install the dependencies per operating system.

Thank you.